404 errors on kaisen-update


First of all I want to congratulate you on this fantastic Linux distribution !

I have all the tools I need out of the box (I could nitpick and say neovim is missing but that’s just a matter of personal preference).

My current issue is on the initial upgrade of my packages after a fresh install of version 2.2 I encountered the following errors (these are 2 out of the 137 error messages) :

E: Failed to fetch https://deb.kaisenlinux.org/pool/main/s/samba/samba-ad-provision_4.17.4%2bdfsg-2_all.deb  404  Not Found [IP : 443]
E: Failed to fetch https://deb.kaisenlinux.org/pool/non-free/u/unrar-nonfree/unrar_6.2.3-2_amd64.deb  404  Not Found [IP : 443]

The errors occur on kaisen-update or apt upgrade or apt upgrade --fix-missing.

After looking at some of the repository folders it seems more recent releases (between the 25/01 and 27/01) are present but not the versions the upgrade is looking for.
eg: samba-ad-provision_4.17.5+dfsg-1_all.deb is present but not samba-ad-provision_4.17.4+dfsg-2_all.deb

Is it possible that the repository package info is wrong after these releases ? Or is something broken on my end ?

Thanks in advance for your help.

Hello and welcome @KongrooParadox!
Thank you to use Kaisen.

Yes, the repositories servers have been migrated to improve rhe performance and the download speed, your problem is probably due because of this.

I checked, and I launched a new index updates. Your problem is normally solved now. It’s okay on your side?

Yes everything works now :slight_smile:

Thank you for the fast response and fix

With pleasure, don’t hesitate to open a new topic if you need. :slight_smile: