Apt dist-upgrade or kaisen-update issues

since today, when I upgrade with “dist-upgrade” or “kaisen-update”, this remove ALL the Kaisen environement, leaving just user apps. Apps like kaisen -design, -skeleton, vlc, virtualbox, and many other are just purged and my desktop “skin” turns to a random Mate instead of the Kaisen one.
Can go backward with timeshift and upgrading with “apt upgrade” don’t change everything like with “dist- or full- upgrade” or “kaisen update” but lots of paquets remains unupgraded…
Am I doing something wrong (my upgrading script was working fine until today), am I missing something, or is there a bug in the process?
(I checked my repo, they remain unchanged on kaisen-rolling, didn’t touch them)

Hello and welcome @YannM!

Probably a bug with MATE. I will check that quickly. Thank you for the feedback.


After a diagnostic, it’s the upgrade of Python in 3.11 version who caused this problem.
I will fix that quickly.

Thx you very much Kevin, I’m happy to help (and to use Kaisen :wink: )

Thanks for that!

In the meantime, you can restore the last working snapshot, from GRUB :slight_smile:
The update of the packages involved (which I maintain myself) is in progress. Once finished, I will do an emergency update in production. It should be good within 2 hours maximum.

yep, I restored from timeshift for my main , but had to do it via Grub for one of my VM.
Pretty useful by the way.
Didn’t even knew timeshift & btrfs before Kaisen, and that’s why I love it: a wonderful tool to learn step by step

You can retry to update your system.

The problem is normally solved now.

Sorry, but not solved for me with kde as per my other post.

How to restore via grub?

Can you don’t write in this topic?
I wrote you in your dedicated topic.

so I tried upgrading my vm for testing:
the GUI stay good but I still lose all the Kaisen apps,
more disturbing, I can’t load old timeshift’s snapshots anymore and the BTRFS options has disapeared from the grub menu.
the automatic snapshot done before upgrading is the only to give me back again de btrfs option in grub, but even with it, my Kaisen apps are still missing.

Oh whoua.

Try to reinstall Kaisen. It’s not normal.

Kaisen has been installed since which version?

It’s OK,
after trying and trying to load different snaps to fix it, my VM turns out to crash definitely, probably a virtualbox issue, nevermind made a new one, who is upgrading in the right way.
So upgraded my main, no problem, everything works well again.
Thx again Kevin :wink:

I’m reassured.

Thank you for your feedback!
Don’t hesitate to open a new topic if you need.