Initramfs-tools issue after kaisen-upgrade

I am getting the following error when updating a two days old install of KDE KaisenLinux:

raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
dpkg: error processing package initramfs-tools (–configure):
installed initramfs-tools package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:

I installed KDE as I had issue with XFCE as per my earlier post.

Altough there are raspberry pi’s on my network. There is no raspberry pi work on this workstation.

I tried deleting the raspi-firmware which did not change a thing and the re-installing it which did not change a thing either.

initramfs is still in a half-configured state:

❯ dpkg -s initramfs-tools
Package: initramfs-tools
Status: install ok half-configured
Priority: optional
Section: utils
Installed-Size: 113
Maintainer: Debian kernel team
Architecture: all
Multi-Arch: foreign
Version: 0.141
Config-Version: 0.141
Provides: linux-initramfs-tool
Depends: initramfs-tools-core (= 0.141), linux-base
Suggests: bash-completion
Breaks: e2fsprogs (<< 1.42.13), initscripts (<< 2.88dsf-59.3~), upstart
Conflicts: linux-initramfs-tool, usplash (<< 0.5.50)
/etc/initramfs-tools/update-initramfs.conf e2026d4603e7161efaccca519aeb1297
/etc/kernel/postinst.d/initramfs-tools c1cb0e052a2cdeef4f3257585c83c58d
/etc/kernel/postrm.d/initramfs-tools e7471d253a5b24e2fd85b40be4e43218
Description: generic modular initramfs generator (automation)
This package builds a bootable initramfs for Linux kernel packages. The
initramfs is loaded along with the kernel and is responsible for
mounting the root filesystem and starting the main init system.

How can I fix this?

Thanks for any help that may be given.

Hello Michel,

Just remove the raspi-firmware package with the following command:
sudo dpkg --purge raspi-firmware

This should solve your problem. Then restart an update with the command sudo kaisen-update.

Hello Kevin,

Yes that resolved the problem. The only (none) issue left is the number of warnings about possible missing firmware for amdgpu. It does not create problems but my workstation has two graphic cards an intel one and an Radeon one. It may mean that the Radeon one is not used?

Thanks again for your prompt attention to these posts.

I am looking forward to running KaisenLinux after quite a few years running pure Debian. I rebuild my workstation after 6 to 12 months use normally.

By default on Kaisen, AMD drivers are not installed same for nvidia drivers.

Try installing the firmware-amd-graphics package with the command sudo apt install firmware-amd-graphics to install the AMD Radeon driver.

No problem, it’s my pleasure :wink:

Yes, I tried that but it came back with: firmware-amd-graphics is already the newest version (20210818-1).

So that is not the issue. It may be a bug with debian (?).

In any case these are only warnings and the system seems to be working and stable. It i simply annoying to have all those warnings popping up at boot. :slight_smile:

Thanks again

I understand, but I can’t do anything about it :slight_smile: