Kaisen Linux | Forum

Kaisen-update = Libsemanage-common not updated

Merry Christmas,

At the start of every day, I usually start with apt update to see if any updates are available, then --upgradable to see which ones and finally use kaisen-update to install everything.
I started with a fresh install of Kaisen 2.0 back on Dec 14 and have run this almost every morning. However, after updating yesterday morning I was left with one item NOT being upgraded, libsemanage-common.
I have tried a number of different things to update/upgrade this and nothing seems to work.
Including the following:

sudo apt-get install -f
sudo dpkg --configure -a
sudo apt-get install -f

and

sudo apt-get clean
sudo apt-get autoclean

I have also tried installing aptitude and using that installer rather than apt — no luck

Results from sudo aptitude install libsemanage-common

“The following packages have been kept back:
libsemanage-common
libsemanage1 : depends : libsemanage-common (= 3.1-1) but 3.3-1 is to be installed”

So then I try:
sudo aptitude install libsemanage1 with the following results

libsemanage1 is already the newest version (3.1-1+b2)

None of this seems to work, and yesterday I gave up.

This morning I tried going back to a previous snapshot to the end of the day before I had this issue using
sudo btrfs-snapshot list and then sudo apt-btrfs-snapshot set-default @date....
This also did not work so I tried to return to a snapshot from a day even earlier. Even after a huge upgrade install same issue. So then I tried to return back to the original snapshot on Dec 14.
And I still cannot upgrade libsemanage-common, it is stuck as not upgraded.

Any help would be appreciated, other than a full reinstall, which I could do but as a last resort.

Merci.

Hello,

This is normal.

It can’t be updated.

This is not a bug. The libsemanage-common library of version 3.1 is needed for systemd to work with libsemanage1 and libsepol1 of the same version.
Version 3.3 has been put on the repositories because new updates will fix this dependency and allow upgrading this package.

I have already reported the problem to Debian.

Re-snapping and re-doing all the updates, or even reinstalling the system will not help, the installed base system requires libsemanage-common 3.1 and an update via APT would break the dependencies, so it doesn’t affect it.

You can upgrade this package when systemd no longer depends on version 3.1 to work.

1 Like

Excellent, thanks for letting me know.