Kaisen Linux | Forum

KDE Plasma loud sound in login screen

Bonjour à tous,

Cela va faire bientôt deux ans que j’installe/désinstalle des distributions Linux sur mon Lenovo (Debian 10/11 impossible, jamais réussi à avoir de GUI, Linux Mint mais je n’ai pas aimé, Kubuntu, pas aimé et des problèmes de son et luminosité, Manjaro KDE/XFCE, pareil, problème de son / luminosité / bluetooth…) et Kaisen Linux arrive à point car elle correspond à ce que je cherche !

Suite à plusieurs installations au cours des deux dernières années, j’ai constamment le même problème.
A force de débug pendant 3 semaines et d’avoir une machine inutilisable, j’abandonnais et passait à autre chose.
Mais c’est trop simple et je veux trouver une vraie solution.

J’ai installé Kaisen sous MATE il y a un mois et il est vrai, je n’ai rencontré aucun des problèmes “commun” que j’avais jusqu’ici.
Seulement, je n’arrive pas à me faire à MATE, je n’apprécie vraiment pas l’interface.

J’ai donc farfouillé dans la documentation et j’ai trouvé le script “kaisen-interface-switcher” qui permet justement de changer de GUI sans réinstallation !

De ce fait, j’ai lancé le script et voulu passer sous KDE, qui est ma GUI préférée.
Tout s’est bien passé (excepté l’icône du menu de lancement des applications qui n’existait plus, rapidement corrigé par moi même) et c’est là que le problème le plus insupportable est revenue.

Lorsque je me connecte à ma session, je constate que le login screen est géré par X11.
Lorsque je fait un retour arrière dans un champ vide (de login ou mot de passe) j’ai un bruit extrêmement fort, provenant de ma carte mère, qui jaillit.

Ce comportement, je l’avais aussi dans firefox, mais j’ai trouvé un fix, directement dans le “about:config” de firefox.

Cependant, pour le login screen, je ne trouve pas.
J’ai fouillé sur internet, où se trouvait les fichiers gérant le son sous KDE/X11/Debian/LIGHT DM … Et je n’ai rien trouvé de probant.

xset b off ne fonctionne pas
renommé des fichiers Oxygen-Sys-Warning.ogg et d’autres, ne fonctionnent pas
Allez dans le menu "Configuration du système → Notifications → Applications : Configurer " et trouver tout les triggers avec du son et tout désactivé à la main ne fonctionne pas
Installer l’utilitaire KMIX et régler manuellement le volume des notifications à 0 ne fonctionne pas
Utiliser l’utilitaire déjà inclus d’audio pour cela, ne fonctionne pas
Couper le son totalement de l’ordinateur via la touche clavier prévu et/ou la GUI, ne fonctionne pas
bloquer le module pcspkr au démarrage ne fonctionne pas non plus

je suis complètement à court d’idées et cela me gâche complètement l’utilisation de cette superbe distribution qui est Kaisen

Je n’ai trouvé aucune solution à l’époque, que ça soit sous Manjaro ou des bases Debian. Mon problème semble très étrange et je suis à bout d’idées.

C’est tout de même un problème extrêmement dérangeant (le bip est vraiment bruyant motherboard beep when keyboard input on Manjaro on Lenovo Ideapad 15 ARE05 (ryzen 7 4800u) - YouTube)

Merci d’avance pour l’aide possible, ce problème apparaît que ça soit avec une installation fraîche sous KDE ou même après migration via le scritp.

Cordialement,

Je pense que votre problème n’est pas si étrange. C’est un comportement de votre matériel, sur certains de mes ordinateurs je l’ai aussi.

Vous avez deux solutions pour régler ce problème, car je n’ai pas connaissance d’une option quelconque ou d’une configuration pour cela, j’y étais confronté aussi.

  • Recompiler Linux et enlever le pilote de ce périphérique afin qu’il puisse ne plus communiquer avec le matériel en question.

  • Démonter votre ordinateur et déconnecter le speaker.

Merci pour le retour :slight_smile:

C’est très étrange qu’en fonction d’une GUI ou d’une autre, sur la même distribution, le problème survient ou pas …

La solution de recompiler Linux est la seule envisageable, l’ordinateur étant un PC portable et ayant besoin des haut parleurs, ce n’est pas une option haha

Je n’ai cependant aucune idée de comment recompiler Linux, je ne sais pas si ceci ce fait “simplement” ou avec des étapes pas à pas sans m’empêcher d’utiliser mes hauts parleurs à tout jamais.

C’est vraiment ce qui me freine dans l’adoption permanente de Linux sur ce matériel car finalement, peu importe la distribution/GUI , les problèmes surviennent.

Merci en tout cas du retour, je vais me renseigner concernant la première option et je note qu’il n’y a pas vraiment de solution à ce jour :frowning:

S’il s’agit d’un comportement matériel lié au speaker, peu de chances de régler le problème logiciellement ou via une option sur l’interface.
Du moins sur MATE et XFCE que je connais le mieux, je n’ai pas vu de telles options de configurations.

Sur mon Lenovo, j’ai le même bruit, je ne le trouve pas spécialement insupportable, cependant le son sort de mes HP internes et non du speaker de la CM.

Si vous coupez le son de votre ordinateur et sur l’écran de verouillage vous appuyez sur la flèche d’effacement avez-vous le même bruit ?

Si tel est le cas, c’est bien qu’il s’agit du speaker de la CM (petit HP intégré à la carte-mère qui fournit ce genre de sons, et pas les haut-parleurs qui vous fournissent le son pour vos activités quotidiennes).

Dans ce que je disais, pardon pour l’imprécision, je parlais du speaker de la CM et non les HP pour vos activités quotidiennes.

Justement, le son en question est très fort (comme le lien de la vidéo youtube que j’ai posté)

Et oui, même l’audio coupé, le son se produit, dans le login screen.
Et c’est exactement ça, lorsque je supprime des caractères, s’il n’y en a plus dans le champ “login/mdp” , cela bip.

Il faudrait que je trouve les plans de la CM de mon Lenovo et que je déconnecte ce composant pour essayer. La méthode est très brutale mais si ça peux m’apporter la paix, je le ferais (mon chat commence à me haïr à force de sursauter)

Ok, c’est donc bien ce que je pensais. Ce n’est pas vos HP, mais bien le speaker de la CM.

En démontant votre ordinateur, vous verrez sûrement le speaker. Il est généralement situé côté capôt arrière.

Une recompilation de Linux pourrait potentiellement faire l’affaire, mais à vérifier.
Le plus simple, et je pense le plus judicieux, serait de l’enlever de la CM.

Tenez-nous au courant sur le forum, je serai intéréssé de connaitre la suite de cela ! :slight_smile:

Bonsoir,

Alors, j’ai démonté le capot et j’ai trouvé le speaker de la CM.
Seulement… je ne trouve qu’un seul connecteur sur la CM qui correspond au speaker.

je veux dire par là que je ne trouve aucun autre composants qui permet de seulement désactiver ce bip sans devoir enlever le connecteur qui permet d’avoir du son sur les HP de l’ordinateur

sur la photo, entouré en rouge, le composant en question
20220311_181510

J’ai réussi à trouver ceci sur internet, un PDF détaillant comment désassembler les composants de l’ordinateur mais je n’ai pas trouvé quelque chose en rapport avec les bips.

Donc j’ai le choix :

  1. Je désactive les hauts parleurs et je n’ai plus de son provenant de cette source.
    Je conserve toujours le son via Bluetooth et prise jack.

  2. Je laisse le haut parleur actif et je dois juste faire en sorte de ne jamais supprimer un caractère de trop lorsque je rentre mes logins de sessions :cry:

ça ne me plait pas mais je ne veux pas perdre mes HP, c’est trop important

Donc tant pis, je vais devoir esquiver ce bip de dingue jusqu’à changer de machine ou devenir fou et retourner en pleurant sur windaube

Merci en tout cas pour l’aide !

Si vous déconnectez les haut-parleurs temporairement, et allumez votre ordinateur, avez-vous toujours ce bruit ?

Si vous ne l’avez plus effectivement vous n’avez pas trop de choix.

Mais je reste persuadé que le bruit ne vient pas de ces HP là, mais celui de la CM.

Avez-vous fait ce test ?

Oui, c’est le premier test que j’ai fais

Le PC était éteint, j’ai débranché ce connecteur, j’ai allumé le PC, j’ai produit le problème et pas de son.
J’ai lancé une vidéo sur YouTube , j’ai bien vérifié l’état des speakers (éteint via kmix et non reconnu par le système , normal puisque déconnecté), j’ai fais les tests jack/bluetooth qui sont OK lorsque je réactive le son via touches clavier ou GUI

J’ai continué de farfouiller côté audio avec pulseaudio, kmix … et c’était bien déconnecté

PC toujours allumé, j’ai remis le connecteur et le son est revenu via les HP

J’ai verrouiller le poste via la commande WINDOWS + L , j’ai essayé de reproduire, pas de bruit (il n’y en a jamais ici)

j’ai fermé la session, j’ai refait le problème et là, ça n’a pas bipé tout de suite mais seulement quand je suis passé du champ vide “login” à celui de “mot de passe” . ensuite, ça le faisait dans les deux champs

j’ai réessayé de multiples fois ces étapes et je cela n’a pas changé le problème initial si le connecteur est branché :frowning:

Je n’ai pas tout compris.

Avez-vous une fois les haut-parleurs déranchés, tenter de reproduire le bruit que vous ne souhaitez plus ?

Oui. Et il n’y avait plus de son. Plus aucun son provenant des hauts parleurs.
j’ai testé en mettant une vidéo youtube et en réactivant le son depuis l’interface graphique.

une fois que j’ai rebranché le connecteur, le son des hauts parleurs est revenu, ainsi que le problème de bip

Ok, ce sont donc vos HP qui font ce bruit, mais il s’agit d’un comportement matériel.

Il est possible potentiellement de régler cela après la modification d’un fichier de configuration d’après quelques recherches.

Avez-vous essayé ceci ?

Bonsoir,

j’ai suivi toutes les indications du lien que vous avez envoyez et enfin… enfin je n’ai plus de bip !!!

mon PC est enfin utilisable sans risquez de voler par la fenêtre.

J’ai suivi les instructions sur mon PC, ça a fonctionné.

J’en ai profité pour procéder à une réinstallation complète et propre de Kaisen Linux KDE (car j’avais fais un peu n’importe quoi avec mes nombreux test et je n’avais rien d’important sur ma session) et tout fonctionne correctement, je suis aux anges.

Je sais maintenant pourquoi je n’ai pas trouvé ces informations, je cherchais des bruits axé CM/speaker et non les sons provenant du terminal… aucune idée de pourquoi est-ce que cela est lié.

De plus, le fichier /etc/inputrc m’était inconnu jusqu’ici

de même que la commande “sudo rmmod pcspkr”

Merci encore, je me mets la solution bien proprement dans un coin au cas où cela revienne.

Je confirme aussi que cela n’affecte pas l’utilisation des hauts parleurs. Aucun problème en bluetooth/jack et en sortie normal.

C’est une bonne nouvelle ! J’en suis ravi.

C’est lié simplement parce que c’est le même module noyau qui gère qui gère les bip système que ce soit sur le terminal ou écran de connexion. Je ne me souvenais plus du nom du module qui le gérait, j’ai orienté mes recherches là dessus, c’est comme cela que j’ai pu trouver rapidement un lien pour ça.

C’est donc effectivement plus rapide de faire une blacklist du module que de recompiler le noyau pour l’enlever :wink:

La commande rmmod permet de supprimer de la mémoire un module noyau, le module en question ici est un pilote qui gère ce bip système qui vous ennuyait tant, et ce module se nomme pcspkr (PC speaker).

Le module noyau pour le son est géré par un autre pilote car le comportement matériel n’est pas le même, pour cela que ça fonctionne encore :slight_smile: