Need help for dual boot

Hello Kaisens!

So I’ve upgraded to a new ssd. Naturally, everything comes from scratch. I was always under the assumption that if you install Windows fisrt and then Linux it would automatically install the grub bootloader so that I have the menu on the linux partition.

Evidently, it’s not the case. When I unplug bootable peripherals I’m in a ditch with a message “no bootable devices found”.

Any suggestions? Thank you, Kaisens.

Hello Rei !

I have several questions :

  • When you installed Kaisen, what was the disk configuration (Ex: one hdd + one sata ssd with old system + new mvme ssd)
  • When you installed Kaisen, you was asked “Would you like to install grub ?” Did you answer “yes” ?
    -After this installation, which boot loader is launching : Windows Boot Loader or Grub ?

To fix your problem, I would sudjest :

  • Retry installtion process.
  • Try update-grub command what will launch os-prober (utility which automaticly will add grub entry for new systems)

Your problem is easly solvable but I will need more information.

Hi Niki,

Here’s the configuration:
kaisen@kaisenlinux ~ $ sudo fdisk -l
Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WD Blue SA510 M.
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x1492befc

Device Boot Start End Sectors Size Id Type
/dev/sda1 2048 104447 102400 50M 7 HPFS/NTFS/exFAT
/dev/sda2 104448 408513614 408409167 194.7G 7 HPFS/NTFS/exFAT
/dev/sda3 408514560 409599999 1085440 530M 27 Hidden NTFS WinRE
/dev/sda4 409602046 781670399 372068354 177.4G 5 Extended
/dev/sda5 409602048 472100863 62498816 29.8G 82 Linux swap / Solaris
/dev/sda6 * 472102912 781670399 309567488 147.6G 83 Linux

At the time of the installation there was a prompt to install grub and i said “yes” but it returned an error.

update-grub gives me something I cannot make sense of:
kaisen@kaisenlinux ~ $ sudo update-grub
/usr/sbin/grub-probe: error: failed to get canonical path of `overlay’.

Any thoughts?


First of first, I saw you’re using m2 ssd so you have a modern system.
Please use GPT instead of MBR. If you don’t want to remove your old windows system, you can convert it by using Microsoft’s MBR2GPT.EXE. Here is the documentation for it :
This will allow you to use more than 4 primary partitions. The custom partitioning will be much eazier. Here is the documentation which explains the difference beetween MBR and GPT :
MBR vs GPT: What's the Difference Between an MBR Partition and a GPT Partition? [Solved]

Once your are done dealing with obsolete partition scheme, I advice you to :

And there is the result :

Free to ask me more questions if needed ; )

1 Like

Hello again Niki,

Thank you very much for the tips. Everything turned out much less prosaic. First when the installation didn’t go through it told me to make EFI partition. So I reinstalled but got the same error.

I got myself a boot-repair usb and followed the steps, but

Then I booted off a live distro and set the bootable flag back to the original sda6 and removed EFI with gparted.

But thanks again for the GPT/MBR info, I’ll definitely keep that in mind for the future.



You don’t need a boot-repair. Your grub isn’t installed.

I guess you’ve selected expert partitionning. If you feel doing like that, please create a 1024Mo EFI partition and format it (if you don’t, it will not work).
Remember, I order the system to boot you will need at least :

  • One EFI partition of 1024Mo
  • One partition formated with linux file system (ext4, btrfs…) mounted as / [root] (minimum 20Go)
  • One partition formated wirh linux file system (ext4, btrfs…) mounted as /home is recommended

In your case you will have one or two additionnal partitions for windows :

  • Windows partition formated with NTFS containg your Windows.
  • One healthy partition for windows of nearly 500Mo (Don’t ask me what it is, idk lol)

If you want, you can take screenshots of every steps you make. Send them to me and I will propose a fix.
Please give me more details when you send a message.

@niki no.

The EFI system partition can be size to 128 or 256Mo max.

For the /home, why is recommended?
If no need to separate the /home partition, don’t touch.

EFI can be greater than 256Mo, see my fdisk -l output (automatic lvm encripted partitionning) :

Device           Start       End   Sectors  Size Type
/dev/nvme0n1p1    2048   1050623   1048576  512M EFI System
/dev/nvme0n1p2 1050624   3051519   2000896  977M Linux filesystem
/dev/nvme0n1p3 3051520 500117503 497065984  237G Linux filesystem

The separate /home is optionnal but recommended by RedHat :

To store user data separately from system data, create a dedicated partition within a volume group for the /home directory. This will enable you to upgrade or reinstall Red Hat Enterprise Linux without erasing user data files.

Source : 9.15.5. Recommended Partitioning Scheme Red Hat Enterprise Linux 6 | Red Hat Customer Portal

The EFI can be greater than 256Mo, but what is the objective?
This partition, both Windows and Linux installation not exceeded 150Mo.

It’s my old partition template who defined 512Mo by default. I fixed that.

For the /home recommandation, not agree.
With my needs, I don’t need to separate the /home :slight_smile:

1 Like

Hi Rei,

Can we close this topic ? Was your problem solved ?

Without answer from your part, the topic will be closed in 48 hours.