No internet

hello kaisens,

Every time I log in I can’t connect to the internet. I’m using a hardwired connection for the moment.

And everytime I cat /etc/resolv.conf I get nameserver ::1. Correcting it does the trick, but I have to do this everytime. It happened on other distros with me from before, but I save the changes and it’s fine.

How do I save the changes permanently? Thank you.

I’m not sure on posting outside links here, but I trust this: How To Set Permanent DNS Nameservers in Ubuntu and Debian

I’m not sure either, but thank you regardless!!

Happy to help.
I assume that sorted things out for you then.

I’ll give it a shot. But the article suggests that you download a separate utility to get it fixed since resolv.conf is updated by the system (systemd deficiency?) every time you reset a hardwired connection. I assumed there is sort of nano-fix-this-conf-file solution, but either way I’ll try that method.

keep us updated, I’ll try to help if needed.
BTW I don’t use or need:

apt policy resolvconf
  Installed: (none)
  Candidate: 1.91+nmu1
  Version table:
     1.91+nmu1 990
        990 sid/main amd64 Packages
        990 sid/main amd64 Packages >


cat cat /etc/resolv.conf

Don’t use my nameserver address, it’s a paid service, so it won’t work for you

also have a look here:


I’ll also use a suspersde in that file:

cat /etc/dhcp/dhclient.conf
# Configuration file for /sbin/dhclient.
# This is a sample configuration file for dhclient. See dhclient.conf's
#	man page for more information about the syntax of this file
#	and a more comprehensive list of the parameters understood by
#	dhclient.
# Normally, if the DHCP server provides reasonable information and does
#	not leave anything out (like the domain name, for example), then
#	few changes must be made to this file, if any.

option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;

send host-name = gethostname();
request subnet-mask, broadcast-address, time-offset, routers,
	domain-name, domain-name-servers, domain-search, host-name,, dhcp6.domain-search, dhcp6.fqdn, dhcp6.sntp-servers,
	netbios-name-servers, netbios-scope, interface-mtu,
	rfc3442-classless-static-routes, ntp-servers;

#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "";
#prepend domain-name-servers;
#require subnet-mask, domain-name-servers;
#timeout 60;
#retry 60;
#reboot 10;
#select-timeout 5;
#initial-interval 2;
#script "/sbin/dhclient-script";
#media "-link0 -link1 -link2", "link0 link1";

#alias {
#  interface "eth0";
#  fixed-address;
#  option subnet-mask;

#lease {
#  interface "eth0";
#  fixed-address;
#  medium "link0 link1";
#  option host-name "";
#  option subnet-mask;
#  option broadcast-address;
#  option routers;
#  option domain-name-servers;
#  renew 2 2000/1/12 00:00:01;
#  rebind 2 2000/1/12 00:00:01;
#  expire 2 2000/1/12 00:00:01;
supersede domain-name-servers;

1 Like

Hello @chyrei,

In the /etc/NetworkManager/NetworkManager.conf, in the [main] section, add the dns=none line.

Like this:


1 Like

much appreciated, sir.