Kaisen Linux | Forum

Openvpn client

Hi,

I wanted to try your distribution so I installed Kaisen on a VM.
I wanted to import my openvpn file configuration (working in my current Ubuntu).
For that I click to Ethernet Network => VPN Connections => Add a VPN connection… => Import a saved VPN configuration… => Create…
I’m choosing my file an click on “Open”.
At this step a window open but with not the good options I don’t have “Identity” but “Proxy”.

Do you have any idea ?

Thanks,
Thomas

Hello,

Have you installed the network-manager-openvpn package?
If not, please install it. You can also get it by upgrading the distribution (post v2, it is installed by default).

After that, you can directly import an ovpn configuration file and the settings will be done automatically according to the configuration :slight_smile:

Thanks for your answer. Yes I’m having this package. And my openvpn configuration is ok because all is right with command line.
20220401_203353

I don’t understand what your problem is.

To configure OpenVPN via NetworkManager:

Right click on the network icon and select edit connections.
Then press +.
And finally click on “Import a saved VPN configuration”.

If your TLS certificates are not integrated in your OVPN file, you must fill them in the tabs provided for after the import of your configuration.

It should work.

The configurations you show, seems to be the configuration for a fortinet VPN.
Try to configure an OVPN access (I see you have an OVPN file on your screenshot).

I am doing what you are saying but after that I have the wrong window.
Look my screenshot from Ubuntu and from Kaisen. Each time I am choosing “Import a saved VPN configuration”
20220401_211512
20220401_211616

I just did it on MATE.
It works very well with the procedure I gave you.

For proof :
1
2
3

You can also configure it this way:
I have anonymized the configuration and I have on my configurations my certificates embedded in the ovpn file. That’s why I left the fields empty.

But you can copy your p12 certificate in these same fields.

1
2
3
4

Hello @Thomas are you solved your problem ?

Hi Kevin,
I just found out today . I don’t know why but had to install network-manager-openvpn-gnome.

Hello Thomas,

Thanks you for your response.

It’s normal, my bad, sorry for this. I forgot include the GNOME plugin with network-manager-openvpn with the updates (with the network-manager-openvpn-gnome package). I had done it on my computer, but I didn’t enter the right package to install in the configurations… :sweat_smile:

I just fix this problem.

The procedure I gave you it works now ?

Hi Kevin,
Yes, everything is fine now.
I am using Kaisen on my work computer.

Thank you for your time and your work.

ps: I know it’s not related to the subject but terminator is not the default terminal so I had to define a Custom Shortcuts and disable “Run a terminal” Shortcuts in Desktop section.
image

Thank you for your feedback, it makes me happy, this is also how I can improve the product :wink:

Can you please open a new topic about this ? That way I’ll ask you more details about this problem so I don’t have to do this or correct it if there is a problem. Thanks :slight_smile: