OpenVPN not working on MATE

Hi all,

I have difficulties to set in gnome the vpn connection.
With the same .ovpn i can connect on terminal, i cant do it in debian gnome interface but in kaisen, i do all steps :
import vpn connection
find my .ovpn files
check everything is ok
click save.

No error showed and no vpn on the top menu, click on the network wifi icon, vpn, no vpn added there, there is just the add vpn connection…

I tried to read the OpenVpn client open previously by someone but it’s not working
I did an apt install network-manager-openvpn-gnome but it was already installed.

Thanks for your help

Hello and welcome @BillyIT!

Sorry for my late reply.

Are you tested your .ovpn file from the openvpn client in CLI?

From officials supported interfaces on Kaisen, openvpn from network-manager works?

On CLI it’s working correctly so i use it like that for now but i’d like to be able to do it with gui.
I don’t understand the last sentences. What do you want me to check?

Thank you for your answer!

Can you send me few screenshots of your problem?

For the moment, I’ve no idea of the origin of your problem.

GNOME is the unique GUI installed on your Kaisen Linux?

Gnome is the unique gui installed (i use the kaisen linux gnome iso)
i took screenshots
when done to import ovpn, i don’t find the vpn on the menu, only the “add a vpn connection”
Capture du 2022-11-21 12-37-59

Kaisen Linux not provides an ISO image with GNOME.

For your problem, try to use a VPN file with Passwords and Certificates directly includes in the .ovpn file.

my mistake it’s the mate gui, not gnome !
ok i’ll try that and try why it’s not worrking too becaure the file .ovpn on cli is working correctly.

Oh okay! I thought that you using a non official ISO file or an image built by you.

Yes, i know.

I has already this problem with this configuration (separates certificates).

Can you send me the output of the sudo systemctl status NetworkManager command after trying to connect to your VPN?
Logs can tell us more.

in /var/log/syslog i had this error :

Blockquotekernel: [ 135.602592] traps: nm-connection-e[2877] trap int3 ip:7fb26b23c7d7 sp:7ffc392b6fd0 error:0 in[7fb26b1fe000+8c000]

systemctl status NetworkManager returns nothing about openvpn (just my wifi that is ok)

I found a solution :
billy@delta7  ~  sudo nmcli connection import type openvpn file openvpn/TantiveII-LAN.ovpn
[sudo] Mot de passe de billy :
Connexion « TantiveII-LAN » (8a1693b4-306e-43d8-98d7-da981466bb37) ajoutée avec succès.

now i have my vpn connection on the networkmanager gui

but i did another thing before and i lost all the small icons that i loved at the right of applications/…/ systems like kaisen terminal etc…
Do you have a command to restore it (i used restore all dashboards because i lost the network icons on the left (i found a solution to add a vpn section on .nmconnection but it was not working)

To restore the default GUI profile, you can follow this guide:

Ok, thank you, i have fully restored the beautiful theme of Kaisen :slight_smile:

For VPN, there is an issue. I have the vpn on the network manager gui but it doesn’t save any settings i put in it like : user / password.
Maybe there is a permission issue ? How can i find that ?

On a forum, i found that we could turn over the problem with the old network manager, need to launch network-manager-editor from cli but i had this error :

billy@delta7  ~  nm-connection-editor
Gtk-Message: 10:19:26.729: Failed to load module “xapp-gtk3-module”

P.S. : i’m trying to find by myself so if i found, i’ll come back.

2022-11-26T10:23:29.727518+01:00 delta7 NetworkManager[27579]: [1669454609.7264] vpn[0x5636316f0830,8a1693b4-306e-43d8-98d7-da981466bb37,“TantiveII-LAN”]: secrets: failed to request VPN secrets #4: No agents were available for this request.
2022-11-26T10:23:29.731326+01:00 delta7 dbus-daemon[29647]: [session uid=1000 pid=29647] Activating service name=‘org.freedesktop.Notifications’ requested by ‘:1.21’ (uid=1000 pid=29893 comm=“nm-applet”)
2022-11-26T10:23:29.732130+01:00 delta7 nm-openvpn[31413]: ERROR: could not read Auth username/password/ok/string from management interface
2022-11-26T10:23:29.732604+01:00 delta7 nm-openvpn[31413]: Exiting due to fatal error
2022-11-26T10:23:29.803404+01:00 delta7 mate-notificati[32755]: Failed to load module “xapp-gtk3-module”

This is from /var/log/syslog. I’m searching the issue

Ok, i had successfully go beyond the problem of no vpn trying to mount
The error was the xapp-gtk3-module missing. I just installed with sudo apt install xapps-common

Now, the vpn tries to mount but the network-manager doesn’t want to record the useername (it saved my password but everytime i went to edit the vpn the username is gone)

I tried to save for all users (solution from posts on others forums)


I found the issue :>

There’s a workaround for this case which worked for me:

You need to edit “/usr/share/glib-2.0/schemas/org.gnome.nm-applet.eap.gschema.xml” and just change one line like you can see here:

gschema: Remove path from eap schema (!44) · Merge requests · GNOME / libnma · GitLab


<schema id=“org.gnome.nm-applet.eap” path="/org/gnome/nm-applet/eap/"gettext-domain=“nm-applet”>


After that you need to run:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

and your done.

Good luck.

This works for me. I could save my username and the vpn is now working correctly (just need to disable all traffic inside the vpn but i think it’s just a checkbox)

Hi all,

Good news, I tried to add a new connection vpn. It was added from network-manager and fully operationnal.
I don’t find the way to modify my post’s title (it wasn’t gnome and to put that it’s solved)
Thanks for your help

Hello @BillyIT, thank you for your feedback!