Updates removing apps & expecting different kernel

OS: Kaisen GNU/Linux 2.3 (rolling) x86_64 
Kernel: 6.4.0-1kaisen-amd64 

Issue: Running kaisen-update (henceforth just update unless otherwise specified) or apt update && apt upgrade removes Ulauncher, ProtonVPN (but not Proton Bridge), Foliate, Bookworm, and various libs. Ulauncher was installed via .deb, and maybe ProtonVPN, but not foliate. This also happens if I open Synaptic, reload, and then select “mark all upgrades.” I also get informed that apt in expecting kernel: 6.4.0-1-amd64 and I may need to reboot to load the newest kernel. The non-kaisen kernel is a boot option but I have never used it.

This first happened maybe a week ago. I run kaisen-update several times a week, and the only reason I noticed is Ulauncher didn’t work.

Steps Taken: I reinstalled foliate, bookworm, ProtonVPN using Synaptic, and Ulauncher using Gdebi. I ran update again and it removed them. Then I rolled-back a week with Timeshift, then updated, and it removed them. Each time I also got the kernel message even though I have never booted using any kernel but Kaisen’s.

Next I opened Synaptic, but instead of marking all upgrades I went to the upgrade section and individually selected them. Never once upon selecting an upgrade did it tell me it was going to remove any of the above packages. However, if I try to upgrade ghostscript Synaptic tells me it will remove ghostscript-x and 3 associated libs. If I say ok those packages become broken and the upgrade will not proceed until I unselect them. However, it still never trys to remove Unlaucher and company.

Here are 3 screenshots (I took them out of order):

  1. synaptic2 shows what happens in Synaptic when I select “mark all upgrades” so it should be 1.
  2. synaptic1 shows what Synaptic says still remains to be updated after I select the other packages that need upgrading and receive no complaints.
  3. synaptic3 shows what Synaptic wants to remove if I try to upgrade them.

I discovered I could only add 1 and merged them, so middle is 1, left is 2, and right is 3 (above).

I don’t know what to do about the kernel, but if I have to I can install Foliate and ProtonVPN via flatpak. I never really used Bookworm and don’t mind it going away. I have been joyfully using KL for 7-8 months, and I really just want to be able to run kaisen-update again without it removing packages I use for no discernible reason.

Thanks for any advice!

I don’t see anyway to edit my post to mark it RESOLVED.

It’s only resolved(ish), but I wanted to post what I did. My thinking was something was indicating it expected a different kernel and also requiring certain conflicting dependencies, either one or multiple applications.

I use KDE Plasma; it’s the Kaisen I installed, and I have used Plasma as my primary DE for years, ever since they finally got it right, IMO. But I like to look at other DEs and apps from them, but I don’t switch to or use them often. So using Synaptic I went application by application and “completely removed” (apt purge) things I never really use:

Probably all of Mate, XFCE, and LXDE and their apps (e.g. Thunar, Pluma, etc), and a lot of Gnome and Openbox. If Synaptic told me when I marked it that any of them would remove something I use I canceled and went to the next “purge”.

After applying these changes, Synaptic did not complain it expected the non-Kaisen kernel, nor did Synaptic try to remove any of the applications it had prior (ULanucher, ProtonVPN, etc). I rebooted to be on the safe side and then ran kaisen-update, and it worked as it always had before. I no longer have the broken packages related to ghostscript either.

Your guess is probably better than mine, but unfortunately it’s been a long time since one could install lots of full-blown DEs on Linux without conflicts, and I suspect something in Mate, et.al wasn’t playing nice, but I dunno.

But I’m generally happy to stick to KDE, Emacs and a handful of other non-distro-specific apps (e.g. LibreOffice, Alacritty) and a few flatpaks.


Why are you add the Bookworm repostirory?

Your problems may be due by this.

I didn’t. AFAIK. See screenshot. If installing 1password or protonvpn via a .deb file pulled in Bookworm repos I was unaware if it. Thanks!

Ah! I get the misunderstanding now! I never went back and read my OP. Bookworm is an E-book reader, like Foliate, not the newest Debian repos.