Kaisen just installed and with 45% of disk used :(

Hello to all of you!

I have just installed Kaisen. I love it!

Now; it’s impossible that a newly installed system already has out of 221 GB, 121 GB free (45,2% occupied)

Well I do not understand what happens {this, maybe because I used upgrade and not kaisen update ?

Which I must have duplicate packages or more than that, I don’t know.

df

$ inxi -Fxxx0
System:
  Host: kaisenlinux Kernel: 5.17.0-kaisen1-amd64 arch: x86_64 bits: 64
    compiler: gcc v: 11.2.0 Desktop: MATE v: 1.26.0 info: mate-panel wm: marco
    v: 1.26.0 vt: 7 dm: LightDM v: 1.26.0 Distro: Kaisen GNU/Linux 2.1
    (rolling)
Machine:
  Type: Desktop Mobo: Gigabyte model: B365M DS3H v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F5
    date: 08/13/2019
CPU:
  Info: 6-core model: Intel Core i5-9400 bits: 64 type: MCP
    smt: <unsupported> arch: Coffee Lake level: v3 rev: D cache: L1: 384 KiB
    L2: 1.5 MiB L3: 9 MiB
  Speed (MHz): avg: 3900 high: 3901 min/max: 800/4100 cores: 1: 3900
    2: 3900 3: 3900 4: 3901 5: 3900 6: 3900 bogomips: 34798
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Gigabyte driver: nvidia
    v: 470.141.03 arch: Turing pcie: speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1f82 class-ID: 0300
  Display: x11 server: X.Org v: 1.21.1.4 compositor: marco v: 1.26.0
    driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 103 s-size: 473x282mm (18.62x11.10")
    s-diag: 551mm (21.68")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102
    size: 480x270mm (18.9x10.63") diag: 551mm (21.68") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA
    470.141.03 direct render: Yes
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel pcie:
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Sound Server-1: ALSA v: k5.17.0-kaisen1-amd64 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: yes
Network:
  Device-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
    v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0
    chip-ID: 10ec:8179 class-ID: 0280
  IF: wlp4s0 state: down mac: 86:3f:eb:29:56:4f
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: c000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp7s0 state: down mac: b4:2e:99:c1:bd:4b
  Device-3: 802.11g Adapter [Linksys WUSB54GC v3] v3 [Ralink RT2070L]
    type: USB driver: rt2800usb bus-ID: 1-9:4 chip-ID: 1737:0077 class-ID: 0000
    serial: 1.0
  IF: wlx687f7465e8d5 state: up mac: 68:7f:74:65:e8:d5
Drives:
  Local Storage: total: 894.26 GiB used: 85.98 GiB (9.6%)
  ID-1: /dev/sda vendor: Western Digital model: WDS480G2G0A-00JH30
    size: 447.13 GiB speed: 6.0 Gb/s type: SSD serial: 19391D800614 rev: 0400
    temp: 34 C scheme: GPT
  ID-2: /dev/sdb vendor: Western Digital model: WDS480G2G0A-00JH30
    size: 447.13 GiB speed: 6.0 Gb/s type: SSD serial: 19391D800656 rev: 0400
    temp: 39 C scheme: GPT
Partition:
  ID-1: / size: 205.51 GiB used: 85.85 GiB (41.8%) fs: btrfs dev: /dev/sdb3
  ID-2: /boot/efi size: 511 MiB used: 134.8 MiB (26.4%) fs: vfat
    dev: /dev/sdb1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nvidia temp: 39 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 56%
Info:
  Processes: 237 Uptime: 14m wakeups: 0 Memory: 15.58 GiB used: 1.83 GiB
  (11.8%) Init: systemd v: 251 target: graphical (5) default: graphical
  Compilers: gcc: 12.2.0 alt: 11/12 Packages: pm: dpkg pkgs: 3226 Shell: Bash
  v: 5.2.0-rc2 running-in: terminator inxi: 3.3.21

Thanks for your help.

Hello and welcome @judd,

Can you send me the result of the command sudo apt-btrfs-snapshot list?

It’s possible due to snapshots automatically taken when an update or packages are installed.

1 Like

Of course!

$  sudo apt-btrfs-snapshot list
[sudo] contraseña para judd: 
Available snapshots:
@apt-snapshot-2022-10-01_14:27:49  
@apt-snapshot-2022-10-01_14:28:46  
@apt-snapshot-2022-10-01_14:29:30  
@apt-snapshot-2022-10-01_14:33:41  
@apt-snapshot-2022-10-01_14:38:00  
@apt-snapshot-2022-10-01_14:50:51  
@apt-snapshot-2022-10-01_15:21:03  
@apt-snapshot-2022-10-01_15:32:14  
@apt-snapshot-2022-10-01_15:36:48  
@apt-snapshot-2022-10-01_18:10:08  
@apt-snapshot-2022-10-01_18:13:05  
@apt-snapshot-2022-10-01_18:14:12  
@apt-snapshot-2022-10-01_18:15:05  
@apt-snapshot-2022-10-01_18:28:20  
@apt-snapshot-2022-10-01_18:30:31  
@apt-snapshot-2022-10-01_18:30:43  
@apt-snapshot-2022-10-01_18:33:44

Oh whoua. There were a lot of them in 4 hours.

Would you like delete all snapshots taken?

2 Likes

It cost me a lot to install it and in the end I did it, by the way the installations with netinstall didn’t work, almost at the end I was getting kernel-panic…
Also, it would not let me select a file system other than Btrfs.

I would like to solve this problem with the snapshots.

Kaisen isn’t installed?

1 Like

If only… I think so

 $ uname -a
Linux kaisenlinux 5.17.0-kaisen1-amd64 #1 SMP PREEMPT Kaisen 5.17.3-1kaisen (2022-04-23) x86_64 GNU/Linux

n

I apologise for the delay in replying, but I speak Spanish and not English. I have to translate and then paste to reply, thank you!

The kernel version currently used isn’t an indicator to check if the system is installed.

But I think that your system is installed, elif the command apt-btrfs-snapshot list wouldn’t have worked.

The installer define BTRFS as default filesystem. But it’s possible to select an other filesystem if you would you like use an other.

The snapshots will not resolves problems due to the installation, snapshots only restores the system before the installation of packages.

1 Like

Thank you for your time and attention !

1 Like

No problem for me, take all the time you need :wink:

1 Like
judd@kaisenlinux ~ $ stat /
  Fichero: /
  Tamaño: 188       	Bloques: 0          Bloque E/S: 4096   directorio
Device: 0,26	Inode: 256         Links: 1
Acceso: (0755/drwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
      Acceso: 2022-10-01 10:33:30.259976855 -0300
Modificación: 2022-10-01 10:33:10.167977642 -0300
      Cambio: 2022-10-01 10:33:10.167977642 -0300
    Creación: 2022-10-01 10:26:56.031992300 -0300
judd@kaisenlinux ~ $ 

$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# systemd generates mount units based on this file, see systemd.mount(5).
# Please run 'systemctl daemon-reload' after making changes here.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda3 during installation
UUID=551525ad-045e-493d-9952-626280b5f8e4 /               btrfs   relatime,discard,compress=zstd,datacow,datasum,barrier,acl,treelog,subvol=@ 0       0
# /boot/efi was on /dev/sda1 during installation
UUID=F1E6-DD20  /boot/efi       vfat    umask=0077      0       1
judd@kaisenlinux ~ $ 

Simply the df -h or lsblk commands can be an indicator.

With my explanations, in relation to your initial question, to resolve your problem, you need to delete many or all snapshots to reduce the disk space currently used.

Would you like delete all snapshots?

1 Like

Thank you!

I have the answer to my question with that :grin:

1 Like

Sure, I have no problems, it breaks, it reinstalls, no problems from my side :+1:

Okay, you have just run this command: sudo apt-btrfs-snapshot delete-older-than 0d

After that, the space disk used will be reduce.

1 Like

Also I have the cpu at more than 100%, I always fix it with pcie_aspm=off and pci=nomsi,noaer in /etc/default/grub
But this was not the case…
htop

Mmmm no ↓

2022-10-01-203317_1920x1080_scrot

Reboot ??

No.
Your CPU isn’t used at more 100%.

It’s normal that each CPU core either a little used.

1 Like